BlockDB Status Page - Main Website is down – Incident details
Docs
Get updates
Email
Docs
Get updates
Experiencing partial outage
Main Website is down
Resolved
Major outage
Started 10 months ago
December 05, 2025
Lasted 24 minutes
December 05, 2025
8:48
9:13 AM
UTC
Affected
Web Properties
Major outage from 8:48 AM to 9:13 AM
Main Website
Major outage from 8:48 AM to 9:13 AM
Updates
Resolved
December 05, 2025 at 9:13 AM
UTC
Resolved
December 05, 2025 at 9:13 AM
UTC
Main Website is back up. This incident was automatically resolved by Instatus monitoring.
Investigating
December 05, 2025 at 8:48 AM
UTC
Investigating
December 05, 2025 at 8:48 AM
UTC
Main Website is down at the moment. This incident was automatically created by Instatus monitoring.
UTC
UTC
UTC
UTC
UTC